프로그래밍/Node.js2017.05.13 03:24
 
 

윈도우에서 npm으로 oracledb 모듈을 설치하던 중에 다음과 같은 에러가 발생했습니다.


MSBUILD : error MSB4132: The tools version "2.0" is unrecognized. Available tools versions are "4.0".


모듈 설치를 위해서 Python 2.7 과 Visual Studio 2017 CE 를 설치해 두었는데, 위와 같은 에러가 발생했습니다.


(참고로 node oracledb를 설치하기 위해서는 Oracle Instant Client 혹은 XE 등이 필요하고, 그 외에 Python 과 C++ 컴파일러가 필요합니다.)



관련해서 검색을 하다가 아래 링크에서 답을 찾았습니다.


https://github.com/chjj/pty.js/issues/60



요점만 적어보면, 


1. 관리자 권한으로 명령 프롬프트를 실행합니다.


2. 다음 명령으로 빌드 관련 툴을 설치합니다.


 npm install --global --production windows-build-tools 


3. 다음 명령으로 빌드 툴에서 사용할 visual studio 버전을 설정합니다.


 npm config set msvs_version 2015 --global


그리고 나서 창을 닫고 새 창을 열어서 다시 시도하니 설치가 잘 되었습니다.







신고
 
 
Posted by ShineUm
분류없음2017.01.23 14:14
 
 

테스트 환경


Ubuntu (16.04.1 LTS)


Virtual Box (V5.1.14)


Vagrant (1.9.1)



먼저 Vagrant 에 대해서 간략히 소개하자면.. 개발환경을 쉽고 빠르게 설정하기 위한 Virtual Machine 관리 툴 입니다. 


Vagrant는 Virtual Box 같은 Virtual Machine 프로그램을 명령어로 제어합니다.



@ Virtual Box 와 Vagrant 설치 


설치는 OS 환경에 따라 약간씩 다르지만 Ubuntu 기준으로 설명합니다. (Windows 나 Mac OS의 경우 GUI 로 쉽게 설치가 가능합니다.)


1) 먼저 Virtual Box 를 설치합니다. 


1. Virtual Box 설치에 앞서서 필요한 의존성 라이브러리들을 설치합니다. 


$ sudo apt install libqt5x11extras5 libsdl1.2debian libsdl-ttf2.0-0


각자 환경에 따라서 위의 라이브러리 이외에도 추가로 필요한 것들이 있을 수도 있습니다.


2. 홈페이지에서 deb 패키지를 다운로드 합니다. (https://www.virtualbox.org/wiki/Linux_Downloads)


3. dpkg 명령어로 다운로드 받은 패키지를 설치합니다. (아래는 5.1.14 버전 예시)


$ sudo dpkg -i  virtualbox-5.1.5.1.14-112924-Ubuntu-xenial_amd64.deb



2) 이번에는 vagrant 를 설치합니다.


1. 홈페이지에서 deb 패키지를 다운로드 합니다. (https://www.vagrantup.com/downloads.html)


2. dpkg 명령어로 다운로드 받은 패키지를 설치합니다. (아래는 1.9.1 버전 예시)


$ sudo dpkg -i vagrant_1.9.1_x86_64.deb 



@ Vagrant Box


Vagrant는 Virtual Machine을 쉽고 빠르게 생성하기 위해서 Box를 이용합니다.


Box 는 Virtual Machine 을 생성하기 위한 이미지 정도로 이해하시면 됩니다.



1) 먼저 Box 관리에 대한 명령어를 알아보겠습니다.


1. 현재 로컬 컴퓨터에서 사용가능한 Box들을 확인하는 방법


$ vagrant box list 



2. 로컬 컴퓨터에 필요한 Box 를 추가하는 방법


먼저 필요한 Box 의 URI를 확인합니다. Vagrant 홈페이지에 있는 Box 링크에서 찾을 수도 있고, (https://atlas.hashicorp.com/boxes/search) 아니면 필요한 Box 이미지를 다운로드 받아서 파일 경로를 지정할 수도 있습니다.


아래 명령어를 사용하면 vagrant 가 Box를 리스트에 추가합니다.


$ vagrant box add [box name or URI] --clean



3. 로컬 컴퓨터에 있는 Box를 제거 하는 방법


필요에 따라 같은 Box의 다른 버전들을 같이 가지고 있는 경우 버전을 명시해 주어야 합니다.


$ vagrant box remove [box name] --box-version [box version] 



4. 로컬 컴퓨터의 Box가 최신 버전인지 확인하는 방법


$ vagrant box outdated --global



@ Virtual Machine 관리 명령어


1. Virtual Machine 생성


$ vagrant init [box name or URI] --box-version [box version]


위의 명령어는 명령어를 실행한 경로에 "Vagrantfile" 을 생성하는데, 이 파일은 실제 Virtual Machine 을 생성할 때 필요한 설정 정보입니다.


실제로 존재하지 않는 위치를 입력해도 "Vagrantfile" 은 생성이 되지만, 다음 과정에 에러가 발생하게 됩니다.


2. Virtual Machine 시작 


$ vagrant up


위의 명령어는 "Vagrantfile" 이 있는 위치에서 실행되어야 하며, 설정파일에 맞게 새 Virtual Machine 을 Virtual Box에 실제로 생성하고 Virtual Machine 을 시작합니다. 만약 로컬 컴퓨터에 존재하지 않는 Box의 경우라도 위의 Box 링크 사이트에서 검색이 가능한 Box의 경우 다운로드하고 로컬 컴퓨터에 Box를 추가하고 나서 Virtual Machine을 생성하게 됩니다.


3. Virtual Machine 에 접속하기


$ vagrant ssh


위의 명령어를 이용해서 해당 Virtual Machine의 ssh 서비스에 접속할 수 있습니다. "Vagrantfile" 이 위치한 곳에서 실행해야 하며, ssh 를 직접 이용하고자 한다면 인증 키를 확인해서 접속할 수 있으나 상당히 번거롭기 때문에 위의 명령어를 이용하는 것이 가장 편합니다. 윈도우 서버를 위한 rdp 나 powershell 명령어도 있는데 제대로 동작하는지 확인은 해보지 못했습니다.


4. Virtual Machine 종료시키기


$ vagrant halt



5. Virtual Machine 삭제하기


$ vagrant destroy



~

신고
 
 
Posted by ShineUm
분류없음2016.10.20 23:39
 
 

Machine Learning 에서 많이 사용되는 Python 기본 설치 방법입니다. 이 포스트에서 Python과 같이 설치할 라이브러리는 Machine Learning에서 필수적으로 사용되는 수치연산을 위한 numpy 와 데이터를 플롯팅 해주는 matplotlib 라이브러리 입니다.


참고로 현재 Python은 3.x 버전이 릴리즈 되었으나 3.x 버전과 2.x 버전의 차이가 크고, 아직은 2.x 버전의 라이브러리가 많아서 2.x 버전도 많이 사용되고 있어서 2.x 버전을 기준으로 정리해 보았습니다. 3.x 버전에서는 numpy 등의 라이브러리가 내장되어 있어서 설치는 용이하겠지만 아직까지는 Machine Learning 책들도 2.x 버전 기준으로 설명을 하고 있어서 2.x 버전 설치 방법을 알아두는 것이 아직은 의미가 있을 듯 합니다.


Python 및 라이브러리 설치 방법은 OS 에 따라서 약간씩의 차이가 있습니다. MacOS 의 경우 기본으로 Python이 설치되어 있고, Linux의 경우 apt 나 yum 등의 명령어로 설치가 가능합니다. 윈도우의 경우 여러가지 설치 방법이 있겠지만 가장 기본적인 설치 방법을 소개해 보겠습니다. 


1. Python 설치

Python은 아래 사이트에서 관리 됩니다.

https://www.python.org/

Download 탭을 클릭해서 2.x 버전 중에 최신버전 (현재 2.7.12)  다운로드 페이지로 갑니다.

본인의 개발 환경에 따라서 32bits 윈도우를 사용하면 Windows x86 MSI installer 를 64bits 윈도우를 사용하면 Windows x86-64 MSI installer 를 선택해서 다운로드 합니다.

다운로드 받은 파일을 더블클릭해서 설치합니다.


2. numpy 라이브러리 설치

Python에서 라이브러리를 설치하는 방법은 여러가지가 있습니다. 크게 세가지 방법이 있는데, 라이브러리를 직접 설치하거나, setup.py 를 실행하거나, pip 를 이용합니다.

numpy 의 경우에도 여러가지 설치 방법이 있는데, 여기서는 setup.py 를 이용해서 설치해 보도록 하겠습니다.

numpy 의 경우는 C++ 로 빌드된 모듈을 참조해서 사용하기 때문에 설치시에 Visual C++ 9.0 컴파일러를 요구합니다.

Visual C++이 설치되어 있지 않다면, 아래 마이크로 소프트 사이트에서 무료로 다운로드 받아서 설치합니다.

https://www.microsoft.com/en-us/download/details.aspx?id=44266


sourceforge 에서 numpy 라이브러리를 다운로드 합니다. 

https://sourceforge.net/projects/numpy/files/NumPy/

numpy 에 대한 최신정보는 아래 사이트에서 확인 가능합니다.

http://www.numpy.org/

최신버전을 다운로드 받았으면, 적당한 곳에 압축을 풉니다. (여기서는 C:\numpy 에 압축이 해제되었다고 가정)


이제 본격적인 설치를 위해서 커맨드 프롬프트를 실행합니다. (윈도우키 + R 누르고 cmd 입력)

numpy 압축해제 경로로 이동


cd C:/numpy


그리고 커맨드 프롬프트 상에서 다음과 같이 실행하여 numpy 를 설치합니다. (python 설치는 C:/Python2.7 에 되어 있다고 가정)


 C:/numpy>C:/Python2.7/python.exe setup.py install 


중간에 라이브러리를 컴파일 하는 시간이 상당히 오래 걸립니다. (사양에 따라 다르겠지만.. CPU도 거의 100% 차지합니다..)

적당히 기다리면 설치가 완료됩니다.


3. matplotlib 설치

관련 자료는 아래 사이트에서 찾아보실 수 있습니다.

http://matplotlib.org/index.html


아래 링크로 가시면 각 OS 별로 라이브러리 설치 방법이 소개되어 있습니다.

http://matplotlib.org/users/installing.html#build-windows


사이트에서는 Python을 처음 설치하면 WinPython 이나 Python(x,y) 등을 이용하길 권장하고 있으나, 표준 Python 설치 환경에서는 pip를 이용하라고 되어 있습니다. 참고로 CentOS (Linux) 에서는 pip 으로 설치가 제대로 되지 않아서, yum으로 설치했던 기억이..


커맨드 프롬프트에서 아래 명령어를 이용해서 설치하면 됩니다.


C:/Python2.7>python.exe -m pip install -U pip setuptools

C:/Python2.7>python.exe -m pip install matplotlib








신고
 
 
Posted by ShineUm
분류없음2015.07.29 23:49
 
 

드디어 Windows 10 이 출시되었습니다.

예전에는 마이크로소프트 사에서 새 소프트웨어를 출시하면 설레이는 마음으로 설치해보곤 했었는데,

언젠가 부터는 맥으로 넘어와서 잘 안쓰게 되었네요..


하지만 저는 서피스를 쓰는 관계로 윈도우와의 인연은 계속 이어가고 있습니다.

기존의 Windows 7 이상의 버전을 사용중인 일반 유저라면 무료로 업그레이드가 가능하며, 

출시일로부터 1년 이내에 업그레이드를 하는 경우 무료로 계속해서 사용이 가능합니다.


일반 설치는 업그레이드 예약을 통해 가능합니다.

자세한 내용은 아래 링크를 통해 마이크로소프트 홈페이지에서 확인 가능합니다.

http://www.microsoft.com/KO-KR/windows/windows-10-upgrade


이번에 새롭게 윈도우10이 출시되자 재미있는 관련 기사가 있어서 링크를 걸어 봅니다. 
http://www.newdaily.co.kr/news/article.html?no=264691 (한눈에 알아보는 업그레이드 변천사)
윈도우 2000대신 ME가 있어야 할거 같고, 각 버전에 대한 자세한 설명은 없고 간략한 소개와 함께 각 버전별로 시작 화면을 기사로 올리셨네요.


한국 마이크로소프트에 있는 윈도우10 관련 Q&A 글입니다.

1. 무료 업그레이드 안내
http://answers.microsoft.com/ko-kr/windows/forum/windows_10-win_upgrade/windows-10%EC%9C%BC%EB%A1%9C-%EB%AC%B4%EB%A3%8C/9a832103-feba-4bee-83f7-b45cccefa5b2?tm=1434942767953

2. 업그레이드 이후 재설치 안내
http://answers.microsoft.com/ko-kr/windows/forum/windows_10-win_upgrade/%EC%97%85%EA%B7%B8%EB%A0%88%EC%9D%B4%EB%93%9C/689f4b13-ab79-446a-8299-ad4b2a7297a6?tm=1434949979274

----

아래 내용에 대해서는 라이센스를 확인한 후에 업데이트 하도록 하겠습니다.
업그레이드가 아닌 클린 설치의 경우 ESD 파일을 다운로드 받아서 ISO로 변경해서 사용하면 됩니다.
이번에 출시된 RTM 버전 윈도우의 빌드 넘버는 10240.16384.150709-1700 이며, 프로 64비트 한국어 버전의 다운로드 링크를 통해서 다운로드가 가능합니다.ESD 파일명은 다음과 같습니다. 
10240.16384.150709-1700.th1_CLIENTPRO_RET_x64fre_ko-kr_7E98F3B91FFE7C6D70F328119CB91CFF7148D98A.esd

ESD 파일을 부팅이 가능한 ISO로 변환하기 위해서는 다음의 과정이 필요합니다.

마이크로소프트 홈페이지 Q&A에 등록되어 있는 것으로 보아 불법은 아닌것 같습니다.

http://answers.microsoft.com/en-us/insider/forum/insider_wintp-insider_install/instructions-create-a-bootable-iso-file-using-esd/d2768b51-221a-436e-af4e-d3b9118a8864?page=1&auth=1


요약해보면 ESD 파일을 받아서 ESD decrypter 를 이용해서 부팅이 가능한 ISO 파일로 변환하는 것입니다.

아래 링크에는 한글로 된 설명이 있습니다.

http://archwin.net/244


위의 설명이 정식 출시 이전에 작성된 것이라서 decrypter 4.7 버전으로 되어 있는데, 새로 출시된 10240 빌드 윈도우 10의 경우 decrypter 6.7 버전을 사용해야 하는 것 같습니다.

아래 링크에서 다운로드가 가능합니다. (바이러스 체크를 안해봤습니다. 혹시나 문제될수 있으니 주의하세요!!)

http://files.fm/down.php?i=uqtmaal&n=esd-decrypter-wimlib-6.7z

프로그램 실행시 가급적 한글명 경로가 없는 곳에서 실행하시는 것이 좋을 것 같네요.. (ex c:/tmp)


변환후에는 자동으로 각 언어에 맞는 파일명으로 iso 파일이 생성되며 한글 윈도우10 프로 64비트 버전의 경우 아래와 같이 파일이 생성되었습니다.

ko_windows_10_pro_10240_x64_dvd.iso


UPDATE : 윈도우10 ISO 파일은 다음 링크에서 다운로드 받으실 수 있습니다.

https://www.microsoft.com/en-us/software-download/windows10ISO


Select edition 에서 Windows 10을 선택하시고 Confirm

그리고 Select the product language 에서 Korean을 선택하시고 Confirm


32-bit or 64-bit 중 필요한 것을 선택하시면 다운로드가 시작됩니다.

참고로 64-bit 를 선택하면 설치시 32-bit 버전을 선택하실 수도 있습니다.



신고
 
 
Posted by ShineUm

티스토리 툴바